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13. Tips for ArcView 3.X
(last updated January 2004)

Extension (.avx): Tools which provide additional functionality to ArcView. They often appear
as a new menu or button when turned on.
* Turn on/off an extension
o0 File > Extensions...
0 Check or uncheck the box next to the name of the extension. Press OK.
* Add a new extension to the list of extensions
o Copy the .avx file for the new extension to the EXT32 folder, typically located at
C:\ESRNAV_GIS30\ARCVIEW\EXT32.
* Change the default extensions that are turned on when ArcView opens.
o0 File > Extensions...
o Turn on/off the extensions as you would have them appear next time ArcView opens.
0 Check the Make Default checkbox and press OK.

Project (.apr): A file which contains all the display settings and locations for the data layers in
your views, tables, and layouts.
* Open/Close/Save project (.apr)
o File > Open/Close/Save Project
0 To Open a project, you must close all projects currently opened.
Set project directory: Identify folder to which calculation and created files will be saved.
o File > Set Working Directory
Create a new view/Open a view: create/open a window for displaying and analyzing map layers
o From project window, select View in the left column. Click the New/Open button above.
Delete a view
0 Select the view to delete in the view list in the project window.
o If the project window is active, there will be a Project menu above.
o0 Project > Delete “ViewName”
Create a new layout/Open a layout: create/open a window for making printable maps.
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o From project window, select view in the left columnIEE. Click the New/Open button
above.

Tile windows: show all open windows at once.
0 Window > Tile

View: A window for displaying and analyzing map layers
* Name the view
o View > Properties

* Set the units to be used for analysis in the view
o View > Properties
* Add a data layer to a view
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Press the + button at the top left corner
OR View > Theme
Select the drive in the Drive drop-down menu in the bottom right-hand corner.
Double click-on the appropriate folders to open them and navigate to your data layer.
Select the data layer type under the Data Source Type drop-down menu
= Select Feature Data Source for point/line/polygon data
= Select Image Data Source for jpgs, tiffs, etc. (To open JPEGSs, turn on JPEG (JFIF)
extension)
= Select Grid Data Source for raster data in the grid format. (Requires Spatial Analyst
extension to be turned on)
= Select Image Analysis Data Source for .img files and to do analysis on the image
you open. (Requires Image Analysis extension to be turned on)
0 Select the data layer to be opened in the list to the left. Use the Shift button to select
several layers at once.
Copy/Cut a data layer from one view to another
o0 Open or select the view window from which the layer will be moved.
0 Select the data layer to be moved from the table of contents (the column on the left-hand
side of the view)
o Edit > Copy/Cut Themes
0 Select the view window to which the layer will be moved.
o Edit > Paste
Remove a data layer from a view
o Edit > Delete Themes
Zoom in/Zoom out in the view window
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o Click on the button and drag a box around the zoom area or click.
o OR View > Zoom in/Zoom out
Zoom to the full extent of the largest data layer in the View

o Click on the button.

0 OR View > Full Extent
Zoom to the full extent of a data layer that you choose

o Click on the button.

o OR View > Zoom to Selected
Move the map to see features that are off the screen

o Click on the @ button.

o Click and drag left to see more area to the right.

o Click and drag right to see more area to the left.
Measure distance in a view

o Click the button.

o Click once in the theme to start the measurement.
o Double-click to end the measurement.

0 The distance appears at the bottom of the view.
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Theme: A data layer displayed in ArcView
* Make a theme visible/invisible in the view
0 Check/uncheck the box next to the theme name
* Select a feature in the view
o Click on the name of the view from which you would like to select feature(s).

o Click the 2] button.
o0 Click on the feature you wish to select

* Select features in the theme based on criteria that you specify
o Click on the name of the view from which you would like to select feature(s).

Click the button.

OR Theme > Query
Create query statement.
Select a set button.
= Press New Set to create a new selection
= Press Add to Set add to a previous selection
= Press Select from Set to do a subselection
* Select features in the theme based on their spatial relationship to other themes
o Click on the name of the view from which you would like to select feature(s).
0 Theme > Select by Theme
0 Choose a spatial relationship
0 Select a set button.
= Press New Set to create a new selection
= Press Add to Set add to a previous selection
= Press Select from Set to do a subselection
* Unselect selected features

o Click on the button.

0 OR Theme > Clear Selected Features
* Create a new theme based on your selection
0 Make a selection from a theme.
o Theme > Convert to Shapefile
0 Save the file.
* Create a new theme and draw the features.
o0 View > New Theme
Select which kind of theme you will create.
Choose where to save it.
All of the tools to draw the features are located in a menu which as a default appears as

[-]

Hold this menu down to see the other options.

Tools are available based on the kind of theme you are creating.
Draw all of your features.

Theme > Save Edits

Theme > Stop Editing.
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Theme functions (continued)
* Change the way a theme is displayed
o Double-click on the name of the theme in the table of contents on the left-hand side of the
view

0 OR click the button.
0 OR Theme > Edit Legend
0 Select the Legend Type
= Single Symbol: all features in the theme are displayed the same way
* Double click on the symbol to edit it in the palette window.
= Graduated Color: display features as a range of colors based on a numeric attribute
(or field)
* Select a field that is numeric in the classification field drop-down menu.
* Change the color ramp in the color ramp drop down menu.

* To flip the color ramp, click the 5_E5| button.

* To flip the order of the values, use the élil buttons.
* To change the number or way that the classes are created, click Classify.
* To edit a specific symbol, double-click on it to bring up the palette window.
* To change the label, click on it and type.

= Unique Value: display features with unique colors based on an attribute (or field)
* Select a field that is numeric in the values field drop-down menu
* Select a color scheme from the color scheme drop-down menu.

* To change the colors randomly, use the Zi=l button.

* To use random patterns, click the @l button.

* To flip the order of the colors, click the 5_E5| button.
* To edit a specific symbol, double-click on it to bring up the palette window.
* To change the label, click on it and type.

0 Legend Editor

= Click on the £ button to change the pattern of a polygon or to set the outline size
of the polygon.

= Click on the ﬁ button to change the style and size of a line feature.
= Click on the E button to change the style and size of a point feature.
8

= Click on the Z&1 button to change the style and font of a theme’s labels.
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Theme functions = Change Display 2 Legend Editor (continued)

= Click on the button to change the color of a feature.
* Select foreground to change color of a polygon interior, a line, or a point.
* Select background to change the background of a pattern for a polygon
* Select outline to change the color of the outline of a polygon.
* Select text to change the color of the labels of a theme.
0 Press Apply to see the changes you made appear in the view.
o Close the legend editor and palette window when you have made all of your changes.
* Turn on labels for the theme you are viewing
0 Select theme to label.
Theme > Properties
Select Labels in the left-hand column.
Select a field in the attribute table to get labels from.
Choose where to display labels and then close the Properties window.
Theme > Auto-Label
= Choose to use the Properties you have just set.
= OR let the computer place them.
* Remove labels.
o0 Select theme from which to remove labels.
o0 Theme > Remove Labels.
* Open the theme table

o Click the button.
0o OR Theme > Table.
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Attribute Table: A table which is linked to a spatial data layer. Each row of the table is a feature in a
data theme. Each column is an attribute of the data.

* Edit Table
o Table > Start Editing
o Edit
= Add Field

* Edit > Add Field
* Give the field a name
* Choose the type of field (String = Text)
* Set the length or maximum number of characters for the field and press OK.
* Table > Save Edits
= Delete a Field
* Select the field to delete.
* Edit > Delete Field
* Table > Save Edits
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Attribute Table 2 Edit (continued)
= Edit a table cell

« Click the 2] putton.
* Click in the cell and type
* Table > Save Edits
= Calculate a field based on another field
* Select field to calculate
* Field > Calculate
* Select the type of field to create.
* Enter formula and press OK.
* Table > Save Edits
o Table > Stop Editing
* Select records in the table based on criteria that you specify

o Click the button.

0 OR Table > Query

o Create query statement

0 Select a set button.
= Press New Set to create a new selection
= Press Add to Set add to a previous selection
= Press Select from Set to do a sub-selection

Layouts: A map design including data layers from the view, a legend, scale bar, north arrow, and
other text.
* Define the layout page.

o Click the Project Window to make it active.

%

o Double-click the icon to create a New Layouit.

o0 Size, orientation, margins or grid could be modified by selecting Layout > Properties or
Page Setup.

* Define frames

o Click on the [®]icon

o Inthe layout page, use the cursor to create a frame.

o0 When the “View Frame Properties” dialog box appears, select the view of choice from the
View section > OK

0 To change size or position of the View Frame, click on the LU > click the view frame.
* Create Legend Frame: represents the table of contents of a view.

o Click and hold down the mouse on the @ button. Release the mouse and click the Legend

Frame tool.

o On the layout, drag the cursor defining a legend frame box.
0 When the “Legend Frame Properties” dialog box appears, double-click on the appropriate
“View Frame”.
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Layouts (continued)

* Add a scale bar: provides reference to measure distance on the map.
o Click the view to make it active. From the View menu (on the menu bar) select “Properties”.
Once in the “Properties” dialog box, select the map units of choice > OK.
o Click on the Layout to make the window active.

o0 Click, holding down the mouse on the Frame tool . Select and click on the Scale Bar

Frame tool E“

o0 On the layout, drag the mouse until defining the Scale Bar Frame.

0 Once the Scale Bar Frame dialog box appears, choose the appropriate view frame
selecting the properties of choice > OK.

e Add a North arrow

0 From the frame tool @I select the North Arrow Frame tool @,
o On the layout, hold the cursor drawing a north arrow frame box.
o0 When the North Arrow Manager dialog box appears, select the arrow of choice.

* Add a title
o On the Window menu (on the menu bar) select Show Symbol Window.
o To change or reset font and letter size, click from the Window menu (from the menu bar)
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“Show Symbol Window”. Once on the Font Palette, select the tool and change it to

choice.

o Click on the lll and move the cursor into the Layout.
o Click at the top of the layout view (or place of preference), and when the Text Properties
dialog box appears, type in the text of choice.

o The E tool is useful to change the position or size of the text size.

This document was created and edited by Laura Baker and Barron Orr.
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